AVR-Doper und SnugBoardv2

Sonntag, Januar 11th, 2009

[singlepic id=91 w=210 h=140 float=left]Hier ist mal wieder ein kleines Update was ich zur Zeit so geschafft habe:

Auf dem Bild seht ihr den AVR-Doper von [1] bzw. von hier [2]. Dabei handelt es sich um einen USB ISP Programmieradapter. Dieser war nötig, da mein Laptop keinen parallelen oder seriellen Anschluss mit bringt.

[singlepic id=90 w=320 h=240 float=right]Über den HID-Modus lässt sich der AVR-Doper sehr einfach zusammen mit AVRDude benutzen. Zum programmieren des ATmega8, der auf dem AVR-Doper läuft, wird natürlich ein anderes Programmiergerät gebraucht. Das habe ich an einem alten Rechner mit meinem Parallelen-ISP-Adapter gemacht.

Zusammen mit einem sehr alten Gehäuse einer Fernbedienung habe ich ein praktischen USP-ISP-Adapter.

Auf dem Bild seht ihr oben des Weiteren das SnugBoardv2 von Pixelklecks.de. Dieses wirklich sehr kleine Board stellt einfach eine Grundbeschaltung für einen Atmega8 o.Ä. bereit und führt die Anschlüsse auf Klemmen oder Stifte heraus. Je nachdem was man auf die Pins der Platine drauf lötet.

Auf dem Bild seht ihr einen sehr simplen Test zum blinken einer LED. Die Platinen habe ich mir selbstverständlich wieder mit dem Toner-Transfer-Verfahren selbst geätzt.

Vielleicht helfen einem von euch die Links zu den Projekten als Denkanstoß.

Als nächstes steht die Ansteuerung von einem Display und ein USB-UART Adapter an. Mal sehen wann ich zwischen den Klausuren dazu komme.

mfg

Andun



Brummen auf den Boxen – Laptop

Freitag, September 12th, 2008

Dies ist ein Artikel für alle, die von dem selben Problem wie ich betroffen sind, in der Hoffnung, dass dieser Artikel über Suchmaschinen gefunden wird.

Folgendes Problem:

Mein neuer Laptop (ein LG P300) steht bei mir auf dem Schreibtisch oft am Netzteil. Also im Netzbetrieb. Schließe ich das Notebook nun an die Stereoanlange über den Line-Out an, habe ich ein Brummen auf der Leitung.

OHNE Ladekabel brummt es nicht. Ich habe mir, auch aus diesem Grund, eine externe USB-Soundkarte gekauft. (Ein anderen Digital-Analog-Konverter kann ja nicht schaden)

Das Brummen ist aber leider geblieben. Nächste Idee: Einen externen USB-Hub dazu geschaltet.

Irgendwie kam mir jetzt schon die Idee, dass das Brummen nicht komplett übers Netzteil in der Leitung weitergetragen wird.

In folgendem Thread bin ich aber auf die Lösung gestoßen:

http://www.hifi-forum.de/viewthread-130-283.html

Das Problem, ist das Antennenkabel in meiner Stereoanlage, da über die verschiedenen Massen eine Brummschleife entsteht. Lösung: Antennenkabel abgesteckt = Brummen weg. (Es handelt sich um einen Kabelanschluss, aber das ist ja an sich egal)

Zur Behebung des Problems, da ich ja auch weiterhin Radio hören will, werde ich mir bei der nächsten Reichelt Bestellung einen Mantelstromfilter mit bestellen, der das Problem beheben sollte.

Ich hoffe damit jemandem helfen zu können.